CVE-2023-54179: 
Linux Kernel vulnerability analysis and mitigation

Overview

CVE-2023-54179 is a buffer overflow vulnerability in the Linux kernel's SCSI QLA2xxx (Fibre Channel) driver, caused by an out-of-bounds array access in string handling code. The array vha->host_str, sized 16 elements, may be accessed at index values 16–19 due to the use of sprintf() instead of snprintf(). It affects Linux kernel versions across multiple stable branches and was publicly disclosed on December 30, 2025. The vulnerability carries a CVSS v3.1 base score of 7.0 (High), requiring local access with low privileges (Red Hat CVE, Feedly).

Technical details

The root cause is a classic stack/heap buffer overflow (CWE-121/CWE-787) in the qla2xxx SCSI driver within the Linux kernel. The driver's string handling code uses sprintf() to write into the fixed-size buffer vha->host_str (16 bytes), but the write operation can use index values 16–19, writing beyond the allocated buffer boundary. This was identified by the Klocwork static analysis tool. Exploitation requires local access with low privileges and high attack complexity, as an attacker would need to trigger the specific driver code path to cause the out-of-bounds write (Red Hat CVE, Red Hat Bugzilla).

Impact

Successful exploitation could allow a local low-privileged attacker to corrupt kernel memory adjacent to the vha->host_str buffer, potentially leading to unauthorized disclosure of sensitive kernel memory contents, violation of data integrity, or a kernel crash resulting in denial of service. In a worst-case scenario, memory corruption could be leveraged for privilege escalation to full system compromise. The impact is rated High across confidentiality, integrity, and availability (Feedly, Red Hat CVE).

Exploitability

There is no known public proof-of-concept exploit and no evidence of in-the-wild exploitation at this time. The EPSS score is approximately 0.032%, reflecting a low probability of near-term exploitation. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires local access, low privileges, and high attack complexity, which significantly limits the practical attack surface (Feedly).

Mitigation and workarounds

Patches are available for multiple Linux kernel stable branches. The vulnerability is resolved in the following versions: 4.19.291+, 5.4.253+, 5.10.188+, 5.15.121+, 6.1.40+, 6.4.5+, and 6.5+. Administrators should update affected systems to the appropriate patched kernel version as soon as possible, prioritizing systems that use the QLA2xxx Fibre Channel HBA driver. As an interim measure, restricting local user access and applying the principle of least privilege can reduce exploitation risk (Feedly, Red Hat Bugzilla).

Additional resources


Source: This report was generated using AI

Related Linux Kernel vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-99099NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-modules
NoYesOct 26, 2026
CVE-2026-99098NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-64k-debug
NoYesOct 26, 2026
CVE-2026-99097NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-rt-core
NoYesOct 26, 2026
CVE-2026-99096NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-debug
NoYesOct 26, 2026
CVE-2026-99094NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-rt-64k-core
NoYesOct 26, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management