CVE-2023-54254: 
Linux Kernel vulnerability analysis and mitigation

Overview

CVE-2023-54254 is a resource leak vulnerability in the Linux kernel's DRM TTM (Translation Table Manager) subsystem. Specifically, the drm/ttm component fails to properly free a resource when an eviction error other than -EMULTIHOP occurs, resulting in a memory/resource leak. The vulnerability affects Linux kernel versions prior to the fixes introduced in stable branches (5.15.124, 6.1.43, 6.4.5, and 6.5). It was published on December 30, 2025, and carries an EPSS score of approximately 0.018% (very low), with no CVSS base score assigned by ENISA (Feedly, EUVD).

Technical details

The root cause is improper resource management (CWE-401: Missing Release of Memory after Effective Lifetime) in the drm/ttm eviction error-handling path of the Linux kernel. When a TTM buffer object eviction fails with an error code other than -EMULTIHOP, the associated resource object is not released, causing a resource leak. The fix ensures that the resource is properly freed in all non--EMULTIHOP error paths, and a v2 of the patch additionally avoids an extra goto statement as suggested by reviewer Andi Shyti. Patches were applied across multiple stable kernel branches (Feedly, EUVD).

Impact

Successful triggering of this vulnerability results in a kernel-level resource leak within the DRM TTM subsystem, which can lead to gradual memory exhaustion or resource starvation on affected systems. Over time, this may degrade system stability and availability, particularly on systems with heavy GPU workloads or frequent buffer eviction operations. There is no known direct path to privilege escalation, data exfiltration, or remote code execution from this vulnerability alone (Feedly).

Exploitability

There is no known public exploit code, active in-the-wild exploitation, or threat actor attribution associated with CVE-2023-54254. The EPSS score is approximately 0.018%, indicating a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Detection plugins exist for Nessus (plugin 281550) and Qualys (IDs 760604, 760600) (Feedly, Tenable).

Mitigation and workarounds

The vulnerability is resolved by updating to patched Linux kernel stable versions: 5.15.124, 6.1.43, 6.4.5, or 6.5 and later. The relevant upstream commits are 7738335d73d0, e9c44738cb1f, 6aea0032380b, and e8188c461ee0 across the respective stable branches. Administrators should apply the appropriate kernel update for their distribution as soon as it becomes available. No configuration-based workaround is known; upgrading the kernel is the recommended remediation (EUVD, Feedly).

Additional resources


Source: This report was generated using AI

Related Linux Kernel vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-99099NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-modules
NoYesOct 26, 2026
CVE-2026-99098NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-64k-debug
NoYesOct 26, 2026
CVE-2026-99097NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-rt-core
NoYesOct 26, 2026
CVE-2026-99096NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-debug
NoYesOct 26, 2026
CVE-2026-99094NONEN/A
  • Linux Kernel logoLinux Kernel
  • kernel-rt-64k-core
NoYesOct 26, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management