
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2025-15497 is a reachable assertion (denial of service) vulnerability in OpenVPN affecting pre-release versions 2.7_alpha1 through 2.7_rc5. Insufficient epoch key slot processing allows remote authenticated users to trigger an assert condition, causing the OpenVPN process to crash. The vulnerability was published on January 30, 2026. It carries a CVSS v4.0 base score of 3.8 (Low), though the availability impact to both the vulnerable system and downstream systems is rated High (Red Hat Advisory, Red Hat Bugzilla).
The root cause is classified as CWE-617 (Reachable Assertion): the epoch key slot processing logic in OpenVPN 2.7 pre-release builds does not sufficiently validate or handle certain conditions, allowing an attacker-controlled input to reach an internal assert statement and abort the process. The attack vector is network-based, requires low privileges (authenticated user), no user interaction, and no special attack requirements, but is rated high complexity. Because the vulnerability is triggered through the VPN's authenticated data path, an attacker must first establish a valid VPN session before sending the malformed epoch key slot data (Red Hat Advisory, Red Hat Bugzilla).
Successful exploitation causes the OpenVPN daemon to crash (process abort), resulting in a complete denial of service for all VPN clients connected to the affected instance. Both the vulnerable system's availability and the availability of downstream systems relying on VPN connectivity are rated High impact. There is no confidentiality or integrity impact — the vulnerability is limited to availability disruption (Red Hat Advisory).
There is no public proof-of-concept exploit and no evidence of in-the-wild exploitation at this time. The EPSS score is approximately 0.045%, reflecting a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities catalog. Exploitation is constrained by the requirement for prior authentication to the VPN and high attack complexity (Red Hat Advisory).
Organizations running OpenVPN 2.7_alpha1 through 2.7_rc5 should upgrade to a patched release once available from the OpenVPN project. Since all affected versions are pre-release (alpha/release candidate), production environments are strongly advised to use the stable OpenVPN 2.6.x series until a patched 2.7 final release is issued. As an interim measure, restrict VPN authentication to trusted users only via network access controls and monitor OpenVPN logs for unexpected process crashes or restarts (Red Hat Advisory, Red Hat Bugzilla).
Fix availability across major Linux distributions and their releases.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."