CVE-2025-43904: 
Linux Debian vulnerability analysis and mitigation

Overview

CVE-2025-43904 is an incorrect authorization vulnerability in SchedMD Slurm's accounting system that allows a Coordinator-role user to improperly promote an unprivileged user to Administrator status. It affects Slurm versions prior to 24.11.5, 24.05.8, and 23.11.11. The CVE was received by MITRE and published on January 16, 2026. It carries a CVSS v3.1 base score of 4.2 (Medium), assigned by MITRE (Feedly, Red Hat Bugzilla).

Technical details

The root cause is classified as CWE-863 (Incorrect Authorization) — the Slurm accounting subsystem fails to properly enforce authorization boundaries between the Coordinator and Administrator roles. A Coordinator, who has legitimate but limited administrative access to the accounting system, can exploit this flaw to elevate another user's privileges to the Administrator level without proper authorization checks. The attack vector is network-based, requires low privileges (Coordinator role), no user interaction, but has high attack complexity. No public proof-of-concept or detailed technical write-up has been published (Feedly, SchedMD Announce).

Impact

Successful exploitation allows a Coordinator to grant Administrator-level privileges to arbitrary user accounts within the Slurm workload manager, resulting in unauthorized administrative control over job scheduling and HPC resource management. An attacker with Administrator access could submit unauthorized jobs, manipulate resource allocations, alter system configurations, and potentially disrupt cluster operations. The confidentiality and integrity impacts are rated low, with no direct availability impact, though the privilege escalation path could enable broader compromise of HPC environments (Feedly).

Exploitability

There is no known public proof-of-concept exploit and no evidence of in-the-wild exploitation at this time. The EPSS score is approximately 0.025% (0.000250), indicating a very low probability of exploitation in the near term. No threat actor attribution has been reported, and the vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires the attacker to already hold a Coordinator role within the Slurm accounting system, which limits the attack surface (Feedly).

Indicators of compromise

  • Logs: Slurm accounting logs (sacctmgr audit logs) showing a Coordinator account modifying user privilege levels to Administrator unexpectedly; review slurmdbd.log for unauthorized AdminLevel=Administrator modifications.
  • Logs: Unexpected new Administrator accounts appearing in sacctmgr list user withassoc format=User,AdminLevel output.
  • Process/Command: Unusual sacctmgr modify user commands issued by Coordinator-level accounts that set AdminLevel=Administrator.
  • Network: Slurm RPC traffic from Coordinator accounts to slurmdbd (default port 6819) performing privilege modification operations outside of normal administrative windows.

Mitigation and workarounds

Organizations should upgrade Slurm to the patched versions: 24.11.5, 24.05.8, or 23.11.11 depending on their current release branch. As interim mitigations, restrict the Coordinator role to only fully trusted personnel, implement access controls limiting who can interact with the accounting system, and audit existing Administrator accounts for unauthorized elevations. Monitor slurmdbd logs for unexpected privilege changes. Debian has issued DSA-5961-1, Ubuntu has issued USN-8236-1, SUSE and Mageia have also released updated packages (SchedMD Announce, Debian Advisory, Ubuntu Advisory).

Community reactions

The EGI CSIRT published a dedicated advisory for this vulnerability shortly after disclosure, highlighting its relevance to HPC and research computing environments (EGI CSIRT). Multiple Linux distributions including Debian, Ubuntu, SUSE, and Mageia have issued security updates, reflecting broad ecosystem attention. Coverage has been largely routine, with no major controversy or significant social media discussion beyond standard security advisory channels.

Additional resources

Linux Distribution fix status

Fix availability across major Linux distributions and their releases.

Debian

Fixed

bookworm

slurm-wlm: 22.05.8-4+deb12u3

Fixed

sid

slurm-wlm: 24.11.5-1

Fixed

trixie

slurm-wlm: 24.11.5-1

Fixed

Ubuntu

Fixed

devel

slurm-wlm

Not Affected

jammy

slurm-wlm

Affected

jammy (esm-apps)

slurm-wlm: 21.08.5-2ubuntu1+esm2

Fixed

noble

slurm-wlm

Affected

noble (esm-apps)

slurm-wlm: 23.11.4-1.2ubuntu5+esm1

Fixed

questing

slurm-wlm

Not Affected

resolute

slurm-wlm

Not Affected

resolute (esm-apps)

slurm-wlm

Not Affected

Source: This report was generated using AI

Related Linux Debian vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-115825NONEN/A
  • Linux Debian logoLinux Debian
  • libplack-perl
NoYesOct 25, 2026
CVE-2026-115824NONEN/A
  • Linux Debian logoLinux Debian
  • starman
NoNoOct 25, 2026
CVE-2026-115823NONEN/A
  • Linux Debian logoLinux Debian
  • starman
NoNoOct 25, 2026
CVE-2026-115822NONEN/A
  • Linux Debian logoLinux Debian
  • starman
NoNoOct 25, 2026
CVE-2026-115817NONEN/A
  • Linux Debian logoLinux Debian
  • starman
NoNoOct 25, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management