
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2025-61657 is a Cross-Site Scripting (XSS) vulnerability in the Wikimedia Foundation's Vector skin, the default skin used by MediaWiki-based wikis including Wikipedia. The flaw is located in the resources/skins.Vector.js/stickyHeader.js file and affects Vector versions prior to 1.43.4 and 1.44.1. It was published on February 3, 2026, and carries a CVSS v4.0 base score of 0.0 (None) under the official scoring, though it is estimated as Medium severity by Feedly due to its XSS nature and network-accessible attack vector (Red Hat CVE, EUVD).
The vulnerability is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation — Cross-Site Scripting) and resides specifically in the sticky header JavaScript component (stickyHeader.js) of the Vector skin. The attack vector is network-based with low attack complexity, but exploitation requires high privileges, suggesting that only users with elevated permissions (e.g., wiki administrators or editors with specific rights) can trigger the vulnerability. The flaw likely involves insufficient sanitization of user-controlled input that is rendered into the page DOM via the sticky header feature, potentially enabling stored or reflected XSS payloads (Wikimedia Phabricator, Red Hat CVE).
Successful exploitation could allow an attacker to inject and execute malicious JavaScript in the context of a victim's browser session on an affected MediaWiki instance. This could lead to session hijacking, credential theft, unauthorized actions performed on behalf of the victim, or defacement of wiki content visible to other users. Given the high-privilege requirement for exploitation, the practical impact is somewhat limited, but privileged accounts on high-traffic wikis (such as Wikipedia) represent high-value targets (Red Hat CVE, Wikimedia Phabricator).
No public proof-of-concept exploit code or evidence of in-the-wild exploitation has been reported for CVE-2025-61657. The EPSS score is approximately 0.054%, indicating a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. The requirement for high privileges further reduces the likelihood of opportunistic exploitation (Red Hat CVE).
Wikimedia Foundation has released patched versions of the Vector skin: 1.43.4 and 1.44.1. Administrators running self-hosted MediaWiki instances should upgrade the Vector skin to one of these versions immediately. No specific configuration-based workaround has been publicly documented; upgrading is the recommended remediation. Wikimedia-hosted properties (e.g., Wikipedia) are managed directly by the Wikimedia Foundation and would have received patches through their standard deployment pipeline (Wikimedia Phabricator, Debian Security).
Debian issued a security advisory (DSA-6085-1) covering MediaWiki, which includes this vulnerability, indicating it was significant enough to warrant a distribution-level security update (Debian Security). A blog post by Bawolff (a MediaWiki developer) titled "How did XSSProtector do?" was published around the same time, suggesting internal reflection on XSS mitigation effectiveness within the Wikimedia ecosystem (Bawolff Blog). No significant broader media coverage or threat actor commentary has been identified.
Fix availability across major Linux distributions and their releases.
bookworm
mediawiki
sid
mediawiki: 1:1.43.5+dfsg-1
trixie
mediawiki: 1:1.43.6+dfsg-1~deb13u1
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."