CVE-2025-6591: 
Linux Debian vulnerability analysis and mitigation

Overview

CVE-2025-6591 is a Cross-Site Scripting (XSS) vulnerability in Wikimedia Foundation MediaWiki, specifically associated with the includes/api/ApiFeedContributions.php file. It affects MediaWiki versions before 1.39.13, 1.42.7, 1.43.2, and 1.44.0. The vulnerability was published on February 2, 2026, and carries a CVSS v3.1 base score of 4.7 (Medium), with a changed scope indicating cross-boundary impact (Red Hat Advisory, Red Hat Bugzilla).

Technical details

The vulnerability is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation — Cross-Site Scripting), rooted in insufficient input sanitization within the ApiFeedContributions.php API endpoint. An unauthenticated remote attacker can craft a malicious request that, when a victim user interacts with it (e.g., clicks a link), causes the browser to execute injected JavaScript in the context of the MediaWiki site. The attack requires no special privileges from the attacker but does require active user interaction, and the scope is changed, meaning the injected script can affect resources beyond the vulnerable component itself (Red Hat Advisory, Red Hat Bugzilla).

Impact

Successful exploitation could allow an attacker to inject malicious scripts into pages served by the MediaWiki instance, potentially stealing session tokens, redirecting users to malicious sites, defacing wiki content, or performing unauthorized actions on behalf of authenticated users. The confidentiality impact is low (limited information disclosure such as session tokens), while integrity and availability are not directly impacted by the XSS itself. The changed scope means the attack can affect browser-side resources beyond the vulnerable endpoint (Red Hat Advisory).

Exploitability

There is no public proof-of-concept exploit available, and no evidence of in-the-wild exploitation has been observed as of the time of reporting. The EPSS score is approximately 0.011% (0.000110), indicating a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires user interaction (a victim must follow a crafted link or visit a malicious page), which further limits opportunistic exploitation (Red Hat Advisory).

Exploitation steps

  1. Reconnaissance: Identify publicly accessible MediaWiki installations running versions prior to 1.39.13, 1.42.7, 1.43.2, or 1.44.0 using search engines, Shodan, or manual version checks via the MediaWiki API (/api.php?action=query&meta=siteinfo).
  2. Craft malicious payload: Construct a URL targeting the ApiFeedContributions API endpoint (/api.php?action=feedcontributions&...) with an XSS payload embedded in a vulnerable parameter that is reflected or stored without proper sanitization.
  3. Deliver the payload: Send the crafted URL to a target user via phishing email, social engineering, or by embedding it in a page the victim is likely to visit.
  4. Trigger execution: When the victim clicks the link and their browser processes the response from the vulnerable endpoint, the injected JavaScript executes in the context of the MediaWiki site.
  5. Achieve objective: The attacker's script can steal the victim's session cookie, exfiltrate CSRF tokens, redirect the user to a phishing site, or perform wiki actions (edits, account changes) on behalf of the victim (Red Hat Advisory).

Indicators of compromise

  • Network: Unusual or malformed HTTP requests to /api.php?action=feedcontributions containing encoded JavaScript payloads (e.g., <script>, javascript:, onerror=, onload=) in query parameters; unexpected outbound connections from user browsers to attacker-controlled domains following interaction with MediaWiki pages.
  • Logs: MediaWiki access logs showing requests to the feedcontributions API endpoint with anomalous or URL-encoded characters in parameter values; repeated requests from the same IP with varying payload patterns.
  • File System: No direct file system artifacts expected for a reflected XSS; however, if the XSS is used to deliver a credential-harvesting payload, check for unexpected new user accounts or privilege escalations in the MediaWiki database.
  • Process/Application: Unexpected JavaScript-driven actions in MediaWiki audit logs (e.g., edits, account changes) attributed to legitimate users at unusual times, potentially indicating session hijacking.

Mitigation and workarounds

Administrators should upgrade MediaWiki to one of the patched versions: 1.39.13, 1.42.7, 1.43.2, or 1.44.0 (or later), depending on the currently deployed branch. As a temporary workaround where immediate patching is not feasible, consider implementing strict Content Security Policy (CSP) headers to limit script execution, restricting access to the ApiFeedContributions API endpoint, and monitoring logs for suspicious activity. Debian users should apply the DSA-5957-1 security update, and Debian LTS users should apply DLA-4249-1 (Red Hat Advisory, Red Hat Bugzilla).

Community reactions

The vulnerability received routine coverage from Linux distribution security channels, including Debian security announcements (DSA-5957-1 and DLA-4249-1) and aggregator sites such as LinuxSecurity.com and LinuxCompatible.org. Vulnerability scanning vendors Tenable (Nessus) and Qualys added detection plugins for the CVE. No notable independent researcher commentary or significant social media discussion has been identified beyond standard advisory distribution.

Additional resources

Linux Distribution fix status

Fix availability across major Linux distributions and their releases.

Debian

Fixed

bookworm

mediawiki: 1:1.39.13-1~deb12u1

Fixed

sid

mediawiki: 1:1.43.3+dfsg-1

Fixed

trixie

mediawiki: 1:1.43.3+dfsg-1

Fixed

Ubuntu

Unknown

bionic (esm-apps)

mediawiki

Unknown

devel

mediawiki

Unknown

focal (esm-apps)

mediawiki

Unknown

jammy

mediawiki

Unknown

jammy (esm-apps)

mediawiki

Unknown

noble

mediawiki

Unknown

noble (esm-apps)

mediawiki

Unknown

resolute

mediawiki

Unknown

Source: This report was generated using AI

Related Linux Debian vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-116612HIGH7.8
  • Linux Debian logoLinux Debian
  • gstreamer-editing-services1.0
NoYesOct 26, 2026
CVE-2026-115909HIGH7.5
  • Linux Debian logoLinux Debian
  • rust-zip
NoNoOct 26, 2026
CVE-2026-115907HIGH7.5
  • Linux Debian logoLinux Debian
  • rust-zip
NoNoOct 26, 2026
CVE-2026-115910MEDIUM6.8
  • Python logoPython
  • social-auth-core
NoYesOct 26, 2026
CVE-2026-2270MEDIUM5.9
  • NixOS logoNixOS
  • kubernetes
NoYesOct 26, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management