
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2025-6593 is an information disclosure vulnerability in Wikimedia Foundation MediaWiki, associated with the includes/user/User.php file. It allows unauthenticated remote attackers to obtain limited sensitive information through user interaction. Affected versions span MediaWiki 1.27.0 through 1.39.12, 1.42.x before 1.42.7, 1.43.x before 1.43.2, and 1.44.0. The vulnerability was published on February 2, 2026, and carries a CVSS v4.0 base score of 2.1 (Low) (Red Hat Advisory, Red Hat Bugzilla).
The vulnerability is classified under CWE-283 (Unverified Ownership) and CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), rooted in improper ownership verification within MediaWiki's user handling logic in includes/user/User.php. The attack vector is network-based with no privileges required, but exploitation requires active user interaction (UI:Active) and specific attack conditions to be present (AT:P), limiting its practical exploitability. No detailed public technical write-up or proof-of-concept code has been identified at this time (Red Hat Advisory, Red Hat Bugzilla).
Successful exploitation results in limited confidentiality impact — specifically, low-level information disclosure affecting both the vulnerable component and system scope — with no integrity or availability impact. The vulnerability requires a victim to interact with a crafted scenario, meaning mass exploitation is unlikely, but targeted attacks against specific users on vulnerable MediaWiki instances remain a concern. There is no evidence of lateral movement potential or significant data exposure beyond limited user-related information (Red Hat Advisory).
No public proof-of-concept exploit code or in-the-wild exploitation has been reported for CVE-2025-6593. The EPSS score is extremely low at 0.012%, reflecting minimal likelihood of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, and no threat actor attribution has been identified. Detection plugins are available from Nessus (plugin IDs 241337 and 242647) and Qualys (detection ID 6264869) (Red Hat Advisory, Tenable Nessus).
Users should upgrade MediaWiki to the patched versions: 1.39.13 or later (for the 1.39.x LTS branch), 1.42.7 or later, 1.43.2 or later, or 1.44.1 or later. Debian has issued security advisories (DSA-5957-1 and DLA-4249-1) with updated packages for affected Debian releases. No configuration-based workarounds have been publicly documented; upgrading to a fixed version is the recommended remediation (Red Hat Bugzilla, Debian DSA, Debian LTS).
The vulnerability received routine coverage through Debian security advisories (DSA-5957-1 for Debian 12 and DLA-4249-1 for Debian LTS), and was picked up by Linux security news aggregators. No notable researcher commentary, vendor statements beyond standard advisories, or significant social media discussion has been identified, consistent with the low severity rating of this vulnerability (Debian DSA, Debian LTS).
Fix availability across major Linux distributions and their releases.
bookworm
mediawiki: 1:1.39.13-1~deb12u1
sid
mediawiki: 1:1.43.3+dfsg-1
trixie
mediawiki: 1:1.43.3+dfsg-1
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."