
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2025-69235 is a Same-Origin Policy (SOP) bypass vulnerability in NAVER's Whale browser that allows remote attackers to manipulate web content within the browser's sidebar environment. It affects all Whale browser versions before 4.35.351.12, developed by Navercorp. The vulnerability was published on December 30, 2025, and a patch was made available in version 4.35.351.12. It carries a CVSS v3.1 base score of 7.5 (High), with no user interaction or privileges required for exploitation (Red Hat CVE, Naver CVE).
The vulnerability is classified as CWE-346 (Origin Validation Error), meaning the browser fails to properly validate the origin of requests or content within its sidebar feature, allowing the Same-Origin Policy to be circumvented. An attacker can exploit this remotely over the network with low attack complexity, no required privileges, and no user interaction, making it straightforward to trigger. The sidebar environment in Whale browser appears to handle cross-origin content in a way that does not enforce standard SOP restrictions, enabling unauthorized cross-origin interactions. No public technical write-up or proof-of-concept code has been identified at this time (Naver CVE, ENISA EUVD).
Successful exploitation allows an attacker to bypass the Same-Origin Policy in Whale browser's sidebar, enabling manipulation or modification of web content across origins. This could lead to data tampering, injection of malicious content (e.g., cross-site scripting), or unauthorized modifications to web applications displayed in the sidebar. The primary impact is on integrity (rated High), with no direct confidentiality or availability impact per the CVSS scoring. Users of Whale browser who rely on the sidebar feature for sensitive web applications are most at risk (Red Hat CVE, Naver CVE).
There is no evidence of active in-the-wild exploitation or a publicly available proof-of-concept at this time. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. The EPSS score is approximately 0.008% (0.000080), indicating a very low probability of exploitation in the near term. Despite the low exploitation likelihood, the attack requires no user interaction and no special privileges, which lowers the barrier for a motivated attacker (Naver CVE, ENISA EUVD).
Users should immediately upgrade Whale browser to version 4.35.351.12 or later, which contains the fix for this vulnerability. No configuration-based workarounds have been publicly documented. Given that exploitation requires no user interaction or elevated privileges, organizations deploying Whale browser should prioritize this update across all installations (Naver CVE, ENISA EUVD).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."