
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2025-69289 is a privilege escalation vulnerability in Discourse, an open-source discussion platform, that allows a non-admin moderator to bypass email-change restrictions and take over non-staff user accounts. It was published on January 28, 2026, and affects all stable versions prior to 3.5.4, versions 2025.11.0 through 2025.11.1, version 2025.12.0, and versions prior to 2026.1.0. The vulnerability carries a CVSS v3.1 base score of 5.4 (Medium) and a CVSS v4.0 base score of 5.1 (Medium) (GitHub Advisory, Red Hat CVE).
The root cause is classified as CWE-863 (Incorrect Authorization) — the platform fails to properly enforce authorization checks when a moderator attempts to change a user's email address. By exploiting an insecure default configuration, a non-admin moderator can bypass the email-change confirmation requirement and reassign a non-staff account's email to an address they control, effectively hijacking the account. Exploitation requires only moderator-level privileges (a low-privilege but non-trivial precondition) and no user interaction, making it exploitable remotely over the network (GitHub Advisory).
Successful exploitation allows a malicious moderator to take full control of any non-staff Discourse user account by changing its associated email address without the account owner's confirmation. This results in unauthorized access to private messages, personal data, and any content or permissions associated with the hijacked account, representing a confidentiality and integrity impact. Availability is not directly affected, and the vulnerability does not impact staff or admin accounts (GitHub Advisory, Red Hat CVE).
No public proof-of-concept exploit code or evidence of in-the-wild exploitation has been reported as of the time of disclosure. The EPSS score is approximately 0.036%, indicating a low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires an attacker to already hold moderator privileges on the target Discourse instance (GitHub Advisory).
require_change_email_confirmation setting that is disabled by default.Discourse has released patched versions: 3.5.4 (stable), 2025.11.2, 2025.12.1, and 2026.1.0. Administrators should upgrade to one of these versions immediately. As a temporary workaround if upgrading is not immediately possible, administrators should either ensure all moderators are fully trusted individuals or enable the require_change_email_confirmation site setting, which forces email confirmation before any email change takes effect (GitHub Advisory).
The advisory was published by Discourse maintainer davidtaylorhq on GitHub on January 28, 2026, and classified as Moderate severity. Coverage has appeared on security aggregation sites including VulnDB, CVEFeed, and CIRCL, as well as brief write-ups on security blogs such as infinitsec.net and ctrlaltnod.com. No significant broader media coverage or notable researcher commentary beyond standard vulnerability tracking has been identified (GitHub Advisory).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."