
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-0966 is a buffer underflow (buffer underwrite) vulnerability in libssh affecting the ssh_get_hexa() API function when processing zero-length input. The flaw also impacts ssh_get_fingerprint_hash() and the deprecated ssh_print_hexa(), and can be triggered remotely via GSSAPI authentication when server logging verbosity is set to SSH_LOG_PACKET (3) or higher. All libssh versions before 0.11.4 are affected, as well as downstream distributions including Red Hat Enterprise Linux 8, 9, and 10, Red Hat OpenShift Container Platform 4, and Microsoft Azure Linux 3 packages. The vulnerability was first reported on February 10, 2026, and published to NVD on March 26, 2026. It carries a CVSS v3.1 base score of 8.2 (High) (Red Hat CVE, Red Hat Bugzilla).
The root cause is classified as CWE-124 (Buffer Underwrite / Buffer Underflow): the ssh_get_hexa() function does not validate that its input length is non-zero before performing memory operations, leading to a buffer underflow condition when a zero-length buffer is supplied. This function is called internally during GSSAPI authentication to log OID values received by the server; a remote, unauthenticated attacker can craft a GSSAPI authentication attempt that causes the server to pass a zero-length OID to ssh_get_hexa(), triggering the underflow. Exploitation requires two preconditions: the server must have GSSAPI authentication enabled, and logging verbosity must be configured at SSH_LOG_PACKET (level 3) or higher. No public proof-of-concept exploit code has been identified at this time (Red Hat Bugzilla, libssh Security Release).
Successful exploitation causes a self-Denial of Service (DoS) of the per-connection daemon process handling the malicious SSH session, crashing that process without affecting other active connections or the main daemon. There is no confidentiality impact (no data exposure), and integrity impact is rated Low per the CVSS scoring. The scope is limited to the individual connection handler, meaning the vulnerability cannot be used for lateral movement, privilege escalation, or remote code execution based on currently available information (Red Hat CVE, Red Hat Bugzilla).
No public exploit code or weaponized tooling has been identified for CVE-2026-0966. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, and there is no evidence of in-the-wild exploitation or threat actor attribution. The EPSS score is approximately 0.086% (0.000860), indicating a very low probability of exploitation in the near term. Exploitation is constrained by the requirement for GSSAPI authentication to be enabled and verbose logging to be active on the target server (Red Hat CVE).
nmap -sV -p 22 or SSH client negotiation).SSH_LOG_PACKET (level 3) or higher — this is a non-default configuration but may be present in debug or high-verbosity deployments.ssh_get_hexa() for logging, triggering the buffer underflow and crashing the per-connection daemon process, resulting in a DoS for that session (Red Hat Bugzilla, libssh Security Release)./var/log/auth.log or /var/log/secure, particularly correlated with GSSAPI authentication attempts; crash stack traces referencing ssh_get_hexa() or GSSAPI OID processing in syslog.sshd child processes (observable via process monitoring or audit logs showing short-lived sshd PIDs); core dump files generated in the SSH daemon working directory if core dumps are enabled.The primary remediation is to upgrade libssh to version 0.11.4 or later (or 0.12.0+), which contains the fix for this vulnerability (libssh Security Release). Red Hat has issued patches via RHSA-2026:18160 (RHEL 10, libssh-0.12.0-2.el10) and RHSA-2026:18683 (RHEL 9), as well as RHSA-2026:7067 for Red Hat Hardened Images (Red Hat RHSA-2026:18160, Red Hat Bugzilla). As a workaround where patching is not immediately possible, administrators can reduce server logging verbosity below SSH_LOG_PACKET (level 3) or disable GSSAPI authentication entirely to prevent remote triggering of the vulnerability.
The libssh project disclosed this vulnerability alongside CVE-2026-0964, CVE-2026-0965, CVE-2026-0967, and CVE-2026-0968 in a coordinated security release on February 10, 2026, releasing versions 0.11.4 and 0.12.0 simultaneously (libssh Security Release). Red Hat rated the issue as Moderate severity and addressed it across RHEL 9 and RHEL 10 in May 2026. Multiple Linux distributions including Ubuntu, SUSE, Slackware, Fedora, and openSUSE issued their own advisories and package updates in the weeks following disclosure, indicating broad ecosystem awareness and response.
Fix availability across major Linux distributions and their releases.
OpenShift
openshift/ose-rhel-coreos-8
RHEL 8
libssh.src
RHEL 9
:appstream:libssh-0:0.10.4-18.el9.src
RHEL 10
libssh-0:0.12.0-2.el10.src
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."