
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-23202 is a race condition vulnerability in the Linux kernel's spi: tegra210-quad driver that can lead to NULL pointer dereference or use-after-free conditions. The flaw exists in the tegra_qspi_combined_seq_xfer() function, where the curr_xfer field is cleared without holding the spinlock, creating a race with the IRQ handler that reads this field. Affected kernel versions include 5.15.198–5.15.199, 6.1.160–6.1.162, 6.6.120–6.6.123, 6.12.63–6.12.69, 6.17.13–6.17.x, 6.18.2–6.18.9, and pre-release 6.19-rc1 through rc8. It carries a CVSS v3.1 base score of 5.5 (Medium) (Feedly).
The root cause is a missing spinlock protection (CWE-476: NULL Pointer Dereference) when clearing the curr_xfer field in the exit path of tegra_qspi_combined_seq_xfer(). The IRQ handler reads curr_xfer without holding the lock to determine whether a transfer is in progress; if the main thread clears this pointer concurrently, the IRQ handler may dereference a NULL or stale pointer. Exploitation requires local access and low privileges, as an attacker would need to trigger the race condition between the combined sequence transfer loop and the interrupt handler. The fix involves wrapping the curr_xfer clearing operation with the existing spinlock (Feedly, Kernel Patch).
Successful exploitation can cause a kernel NULL pointer dereference or use-after-free, resulting in a system crash (kernel panic) and denial of service. The vulnerability has no confidentiality or integrity impact — only availability is affected, as the kernel crash would render the system unavailable until rebooted. The scope is limited to the local system running an affected kernel with the Tegra210 QSPI hardware driver active (Feedly).
No public proof-of-concept exploit code or in-the-wild exploitation has been reported for CVE-2026-23202. The EPSS score is approximately 0.024% (0.000240), indicating a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation is constrained to local, low-privileged attackers on systems with Tegra210 QSPI hardware, significantly limiting the attack surface (Feedly).
The Linux kernel maintainers have released patches addressing this vulnerability across multiple stable branches. Fixed versions include 5.15.200, 6.1.163, 6.6.124, 6.12.70, 6.18.10, and the upstream fix is included in 6.19 stable. Downstream distributions including Debian, Ubuntu, SUSE, and Oracle Linux have issued updated kernel packages. Administrators should apply the latest kernel update for their distribution as soon as possible; no configuration-based workaround is available (Kernel Patch, Debian LTS, OpenSUSE).
Fix availability across major Linux distributions and their releases.
bionic
linux
bionic (esm-infra)
linux
bionic (fips-updates)
linux-fips
bionic (fips)
linux-fips
devel
linux
focal
linux
focal (esm-infra)
linux-hwe-5.15: 5.15.0-185.195~20.04.1
focal (fips-updates)
linux-fips
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."