
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-23280 is an integer overflow vulnerability in the Linux kernel's accel/amdxdna driver that can lead to memory corruption. The flaw exists in the ubuf size calculation, where an arithmetic overflow can produce an undersized memory allocation, enabling potential memory corruption and arbitrary code execution. It affects Linux kernel versions 6.18.x before 6.18.17, 6.19.x before 6.19.7, and 7.0-rc1. The vulnerability was disclosed on March 25, 2026, and carries a CVSS v3.1 base score of 7.8 (High) (Red Hat Advisory, Red Hat Bugzilla).
The root cause is an integer overflow or wraparound (CWE-190) in the accel/amdxdna driver's ubuf size calculation. When computing the size of a user buffer allocation, the arithmetic can wrap around to a smaller value, causing the kernel to allocate an undersized buffer. Subsequent writes to this buffer can corrupt adjacent kernel memory. The fix applies check_add_overflow() helpers to validate the size calculation before the allocation is performed, preventing the overflow condition (Red Hat Bugzilla, Kernel Patch). Exploitation requires local access with low privileges sufficient to interact with the AMD accelerator device node.
A local attacker with low privileges and access to the AMD XDna accelerator device can trigger the integer overflow, resulting in an undersized kernel memory allocation. This memory corruption can lead to arbitrary code execution in kernel context, as well as high impacts on confidentiality, integrity, and availability of the affected system (Red Hat Advisory). The scope is limited to the local system, but successful kernel-level code execution could enable full privilege escalation and complete system compromise.
There is no public proof-of-concept exploit available, and no evidence of in-the-wild exploitation has been reported (Red Hat Advisory). The EPSS score is approximately 0.017%, reflecting a low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires local access to the system and privileges to interact with the AMD XDna accelerator device node, limiting the attacker pool.
Upgrade to a patched Linux kernel version: 6.18.17 or later, 6.19.7 or later, or 7.0-rc2 or later. Patches are available via the upstream kernel stable tree (Kernel Patch 6.18.x, Kernel Patch 6.19.x, Kernel Patch 7.0). As a temporary workaround until patching is complete, restrict access to AMD accelerator device nodes (e.g., via udev rules or file permissions) to limit exposure to trusted users only (Red Hat Advisory).
Fix availability across major Linux distributions and their releases.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."