CVE-2026-23422: 
Linux Debian vulnerability analysis and mitigation

Overview

CVE-2026-23422 is a vulnerability in the Linux kernel's dpaa2-switch network driver that can cause an interrupt storm when a malformed or out-of-bounds interface ID (if_id) is received in the IRQ handler. The flaw was introduced as a side effect of commit 31a7a0bbeb00, which added bounds checking for if_id to prevent out-of-bounds memory access but failed to clear the interrupt status register upon detecting an invalid if_id, leaving the interrupt line asserted indefinitely. It was discovered by an experimental AI code review agent at Google and disclosed on April 3, 2026. Affected Linux kernel versions include 5.15.200–5.15.202, 6.1.163–6.1.166, 6.6.124–6.6.129, 6.12.70–6.12.76, 6.18.10–6.18.16, 6.19.1–6.19.6, and 7.0-rc1 through rc7. The CVSS v3.1 base score is 7.8 (High) (Feedly, GitHub Advisory, Red Hat CVE).

Technical details

The root cause is classified under CWE-392 (Missing Report of Error Condition) and CWE-787 (Out-of-bounds Write). In the dpaa2-switch IRQ handler, when an incoming if_id value falls outside the valid range, the handler returns early to avoid an out-of-bounds array access — but does so without clearing the hardware interrupt status register. Because the interrupt line remains asserted, the CPU re-enters the handler in a tight loop, producing an interrupt storm. The fix requires explicitly clearing the interrupt status register even in the error path when an out-of-bounds if_id is detected. The attack vector is local (AV:L), requires low privileges (PR:L), and no user interaction (Feedly, GitHub Advisory).

Impact

Successful exploitation results in an interrupt storm that causes severe system performance degradation and potential system crashes, constituting a denial-of-service condition. The vulnerability primarily affects availability, though the CVSS score also reflects high confidentiality and integrity impact (likely due to the potential for memory corruption via the underlying out-of-bounds write path). Systems running affected Linux kernel versions with dpaa2-switch-capable NXP DPAA2 network hardware are at risk (Feedly, GitHub Advisory).

Exploitability

There is no public proof-of-concept exploit and no evidence of in-the-wild exploitation at this time. The EPSS score is approximately 0.024% (0.000240), indicating a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires local access with low privileges on a system equipped with dpaa2-switch-capable hardware (Feedly).

Indicators of compromise

  • Logs: Kernel logs (dmesg or /var/log/kern.log) showing repeated IRQ handler invocations or messages related to dpaa2-switch with invalid if_id values; high interrupt counts on the dpaa2-switch IRQ line visible via /proc/interrupts.
  • System Behavior: Sudden and sustained CPU utilization spike attributed to interrupt handling (softirq/hardirq), system becoming unresponsive or sluggish without obvious user-space cause.
  • Network: Unusual or malformed Ethernet frames arriving on dpaa2-switch interfaces with crafted or invalid interface identifiers.

Mitigation and workarounds

Update the Linux kernel to one of the following patched versions: 5.15.203, 6.1.167, 6.6.130, 6.12.77, 6.18.17, 6.19.7, or 7.0-rc3 (and later). Multiple patch commits are available in the Linux kernel stable tree. As a temporary workaround for systems that cannot be immediately patched, consider disabling or restricting access to dpaa2-switch network interfaces if they are not actively required, and implement network segmentation to limit exposure. Monitor system logs for signs of interrupt storms or unusual CPU utilization (Feedly, GitHub Advisory).

Community reactions

The vulnerability was notably discovered by an experimental AI code review agent at Google, which was highlighted in the CVE description as a demonstration of AI-assisted vulnerability discovery in open-source kernel code. No significant public researcher commentary or media coverage beyond standard vulnerability tracking has been observed (Feedly).

Additional resources

Linux Distribution fix status

Fix availability across major Linux distributions and their releases.

Debian

Fixed

bookworm

linux: 6.1.170-1

Fixed

sid

linux: 6.19.8-1

Fixed

trixie

linux: 6.12.85-1

Fixed

RHEL / CentOS

Affected

RHEL 8

Not Affected

RHEL 9

Not Affected

RHEL 10

Not Affected

Source: This report was generated using AI

Related Linux Debian vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-116612HIGH7.8
  • Linux Debian logoLinux Debian
  • gstreamer-editing-services1.0
NoYesOct 26, 2026
CVE-2026-115909HIGH7.5
  • Linux Debian logoLinux Debian
  • rust-zip
NoNoOct 26, 2026
CVE-2026-115907HIGH7.5
  • Linux Debian logoLinux Debian
  • rust-zip
NoNoOct 26, 2026
CVE-2026-115910MEDIUM6.8
  • Python logoPython
  • social-auth-core
NoYesOct 26, 2026
CVE-2026-2270MEDIUM5.9
  • NixOS logoNixOS
  • kubernetes
NoYesOct 26, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management