
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-23957 is a Denial of Service vulnerability in the seroval npm package, a JavaScript value serialization library, caused by improper handling of encoded array lengths during deserialization. An attacker can override the encoded array length field with an excessively large value, causing the deserialization process to consume disproportionate processing time. All versions up to and including 1.4.0 are affected; version 1.4.1 introduces the fix. The vulnerability was published on January 21, 2026, and carries a CVSS v3.1 base score of 7.5 (High) (GitHub Advisory, Seroval Advisory).
The root cause is classified as CWE-770 (Allocation of Resources Without Limits or Throttling). During deserialization, seroval previously trusted the encoded array length value embedded in the serialized payload. An attacker can craft a malicious payload that replaces this length field with an arbitrarily large integer, forcing the deserializer to attempt to allocate or iterate over a massive array, significantly increasing CPU and memory consumption. The fix removes reliance on the encoded length entirely, instead computing array length dynamically via Array.prototype.length at deserialization time, eliminating the attack surface (GitHub Advisory, Patch Commit).
Successful exploitation results in a Denial of Service condition affecting the availability of any Node.js application or service that deserializes untrusted seroval-encoded data. There is no impact on confidentiality or data integrity. Depending on the application architecture, a sustained attack could render the affected service unresponsive, potentially impacting downstream users or dependent services (GitHub Advisory).
No public proof-of-concept exploit code or evidence of in-the-wild exploitation has been reported. The vulnerability requires no authentication, no user interaction, and has low attack complexity, making it straightforward to exploit against any internet-exposed service that deserializes attacker-controlled seroval payloads. The EPSS score is approximately 0.036–0.041%, indicating a low near-term exploitation probability. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities catalog (GitHub Advisory).
seroval library (versions ≤ 1.4.0).2^31 - 1 or similar), while keeping the actual array content minimal.Upgrade the seroval npm package to version 1.4.1 or later, which resolves the vulnerability by computing array lengths via Array.prototype.length instead of trusting the encoded value (Patch Commit, GitHub Advisory). As a workaround prior to patching, avoid deserializing untrusted or user-supplied seroval payloads, and implement input validation or size limits on data passed to the deserializer. Rate limiting on endpoints that perform deserialization can also reduce the impact of exploitation attempts.
The vulnerability was credited to researcher tweidinger and coordinated by the library maintainer lxsmnsyc, who published the advisory and patch simultaneously on January 21, 2026 (Seroval Advisory). Brief mentions appeared on Mastodon and security aggregator sites shortly after disclosure, but no significant broader media coverage or notable researcher commentary has been identified.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."