
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-24742 is an incorrect authorization vulnerability in Discourse, an open source discussion platform, that allows non-admin moderators to view sensitive information in staff action logs restricted to administrators. Disclosed on January 28, 2026, it affects Discourse versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. It carries a CVSS v3.1 base score of 6.5 (Medium) (GitHub Advisory, Red Hat CVE).
The vulnerability is classified as CWE-863 (Incorrect Authorization), meaning the platform performs an authorization check when moderators access staff action logs but does not correctly enforce the restriction to administrators only. A low-privileged authenticated user with moderator role can access the staff action logs endpoint over the network without any additional complexity or user interaction. The exposed data includes webhook payload URLs and secrets, API key details, site setting changes, private message content, restricted category names and structures, and private chat channel titles. No public proof-of-concept exploit code has been identified at this time (GitHub Advisory).
Successful exploitation allows a moderator to extract highly sensitive administrative credentials and configuration data, including webhook secrets and API keys, which could be used to spoof webhook events to integrated third-party services or escalate access beyond the Discourse platform. Private message content and restricted category structures are also exposed, creating significant confidentiality risks for platform users. There is no integrity or availability impact, but the credential leakage could enable downstream attacks on integrated services (GitHub Advisory).
No public exploit code or evidence of in-the-wild exploitation has been reported for CVE-2026-24742. The EPSS score is approximately 0.028%, indicating a low probability of exploitation in the near term. The vulnerability requires a low-privilege authenticated account (moderator role), limiting the attack surface to users who have already been granted moderator access. It is not currently listed in the CISA Known Exploited Vulnerabilities (KEV) catalog (GitHub Advisory, Red Hat CVE).
/admin/logs/staff_action_logs) by moderator-level accounts (non-admin users) in Discourse application logs.Discourse has released patched versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, which restrict staff action log access to administrators only. Administrators should upgrade to one of these versions immediately. As a temporary workaround, site administrators should review all moderator appointments and limit the role to fully trusted users, as there is no configuration-based option to prevent this access in unpatched versions. Additionally, rotating any webhook secrets and API keys that may have been exposed is strongly recommended after upgrading (GitHub Advisory).
The vulnerability was published by Discourse maintainer davidtaylorhq via GitHub Security Advisories on January 28, 2026, with a moderate severity rating. Coverage has been limited to vulnerability aggregator sites and a brief write-up on Infinitsec. No significant broader media coverage or notable researcher commentary has been identified (GitHub Advisory).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."