
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-28218 is a fail-open access control vulnerability in the Discourse Data Explorer plugin that allows any authenticated user to execute SQL queries lacking explicit group assignments, including built-in system queries. It affects Discourse versions prior to 2025.12.2, versions 2026.1.0 up to (but not including) 2026.1.1, and versions 2026.2.0-latest prior to 2026.2.0. The vulnerability was published on February 26, 2026, and patched versions were released the same day. It carries a CVSS v3.1 base score of 5.4 (Medium) and a CVSS v4.0 base score of 5.3 (Medium) (GitHub Advisory, Red Hat CVE).
The root cause is improper access control (CWE-284) in the discourse-data-explorer plugin, where the access control logic defaults to permitting access (fail-open) when a Data Explorer query has no explicit group assignments. This means any authenticated user — regardless of their role or group membership — can invoke SQL queries that were intended to be restricted, including built-in system queries. The attack vector is network-based, requires only low privileges (a valid authenticated session), and no user interaction or special conditions are needed (GitHub Advisory).
Successful exploitation allows authenticated users to execute arbitrary pre-defined SQL queries against the Discourse database, potentially exposing sensitive forum data such as user information, private messages, email addresses, and other internal records. The confidentiality impact is rated low-to-moderate, with no direct integrity or availability impact assessed. However, depending on the content of the accessible queries, data exposure could be significant in forums handling sensitive community or organizational information (GitHub Advisory, Red Hat CVE).
No public proof-of-concept exploit code or in-the-wild exploitation has been reported for CVE-2026-28218. The EPSS score is approximately 0.031% (0.000310), indicating a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires only a valid authenticated account on the target Discourse instance, making it accessible to any registered forum member (GitHub Advisory).
discourse-data-explorer plugin enabled./admin/plugins/explorer or equivalent endpoint accessible to authenticated users)./admin/plugins/explorer) by non-admin or non-privileged user accounts in Discourse application logs./admin/plugins/explorer/queries/:id/run) that would not normally be expected from those accounts.Discourse has released patched versions 2025.12.2, 2026.1.1, and 2026.2.0 that address the fail-open access control issue. Administrators unable to upgrade immediately should apply one of two workarounds: explicitly assign group permissions to every Data Explorer query that currently has no group assignments (including built-in system queries), or disable the discourse-data-explorer plugin entirely until the patch can be applied. Upgrading to a patched version is the recommended long-term solution (GitHub Advisory).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."