
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-2923 is an out-of-bounds write vulnerability in GStreamer's DVB Subtitles handling that allows remote attackers to execute arbitrary code on affected installations. The flaw was reported to the vendor on 2026-02-11 and publicly disclosed on 2026-03-06 via a coordinated Zero Day Initiative advisory (ZDI-26-161, originally tracked as ZDI-CAN-28838). All GStreamer versions prior to 1.28.1 are affected. It carries a CVSS v3.0 base score of 7.8 (High) (ZDI Advisory, Red Hat Bugzilla).
The vulnerability is classified as CWE-787 (Out-of-bounds Write) and resides in GStreamer's coordinate handling logic within its DVB Subtitles parser. Insufficient validation of user-supplied data allows a write operation to exceed the bounds of an allocated heap buffer. An attacker can trigger this flaw by supplying a maliciously crafted media file or stream containing malformed DVB subtitle coordinates; because GStreamer is a library, the specific attack vector depends on how the consuming application exposes it (e.g., media players, streaming services). The fix is available in the upstream commit at https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/3b8253f447bcc9831dbf643d2c69b205fedbe086 (ZDI Advisory, Red Hat Bugzilla).
Successful exploitation allows an attacker to execute arbitrary code in the context of the process using the GStreamer library, with full confidentiality, integrity, and availability impact on that process. Because GStreamer is widely embedded in media players, desktop environments, and streaming applications, the affected asset scope is broad across Linux-based systems. While the CVSS attack vector is local (requiring user interaction such as opening a malicious file), the vulnerability description notes that attack vectors may vary depending on the implementation, potentially enabling remote exploitation in network-facing media processing pipelines (ZDI Advisory, Red Hat Bugzilla).
No confirmed exploit code or proof-of-concept has been publicly released; the ZDI advisory is descriptive only and contains no exploitation details or payload (ZDI Advisory). There is no evidence of in-the-wild exploitation, no threat actor attribution, and the vulnerability is not listed in the CISA Known Exploited Vulnerabilities catalog. The EPSS score is approximately 0.063%, reflecting low near-term exploitation probability (Feedly). User interaction (e.g., opening a crafted media file) is required, which further limits opportunistic exploitation.
.ts, .mkv, .mp4) in download or temp directories with anomalous DVB subtitle tracks; unusual files written to /tmp or user home directories by media player processes./bin/sh, curl, wget, or python); crashes or core dumps from GStreamer-linked processes (gst-launch, totem, rhythmbox).dmesg or journalctl entries showing segmentation faults in processes linked to libgstdvbsuboverlay.so or related GStreamer plugin libraries.Update GStreamer to version 1.28.1 or later, which includes the upstream fix (GStreamer Commit). Red Hat has issued patches for RHEL 8 (RHSA-2026:6750), RHEL 9 (RHSA-2026:6300, RHSA-2026:8862, RHSA-2026:19180), and RHEL 10 (RHSA-2026:6259, RHSA-2026:8854, RHSA-2026:19024); Debian and AlmaLinux have also released updates (Red Hat Bugzilla). As a workaround where patching is not immediately possible, restrict or disable processing of untrusted media files containing DVB subtitle streams, and avoid exposing GStreamer-based applications to untrusted network streams.
The vulnerability was credited to an anonymous researcher and disclosed through the Zero Day Initiative's coordinated disclosure process (ZDI Advisory). It received coverage from Linux security news aggregators and distribution security mailing lists (Yocto, Debian, Fedora, AlmaLinux, Rocky Linux), reflecting standard community response to a library-level media parsing flaw. No notable individual researcher commentary or significant social media discussion beyond routine security advisory tracking has been identified.
Fix availability across major Linux distributions and their releases.
bookworm
gst-plugins-bad1.0: 1.22.0-4+deb12u7
sid
gst-plugins-bad1.0: 1.28.1-1
trixie
gst-plugins-bad1.0: 1.26.2-3+deb13u1
bionic (esm-apps)
gst-plugins-bad1.0
devel
gst-plugins-bad1.0
focal (esm-apps)
gst-plugins-bad1.0
jammy
gst-plugins-bad1.0
jammy (esm-apps)
gst-plugins-bad1.0
noble
gst-plugins-bad1.0
noble (esm-apps)
gst-plugins-bad1.0
resolute
gst-plugins-bad1.0
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."