
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-33250 is a stack-based buffer overflow vulnerability in Freeciv21, a free open-source turn-based strategy game, caused by recursive processing of specially-crafted compressed (jumbo) packets. All versions prior to 3.1.1 are affected across all supported platforms including snap, Windows, Mac, Debian packages, Arch User Repository, and Flatpak distributions. The vulnerability was discovered and published on March 21–24, 2026, with a patch released simultaneously. It carries a CVSS v3.1 base score of 7.5 (High) (GitHub Advisory, Feedly).
The root cause is improper input validation (CWE-20) leading to a stack-based buffer overflow (CWE-121) in the packet decompression logic of common/networking/packets.cpp. Freeciv21's network protocol supports compressing individual packets or merging streams into "jumbo" packets; the vulnerable implementation recursively called get_packet_from_connection() when processing jumbo packets, allowing a malicious sender to craft nested jumbo-within-jumbo packets that trigger unbounded recursion and stack exhaustion. No authentication is required to send such packets, and by default the application logs do not record sufficient information to detect the attack. The fix (commit ad8e18c) eliminates the recursion by refactoring decompression into a separate non-recursive decompress_buffer() function and explicitly rejecting any compressed packet found inside a decompressed result (zip-bomb prevention) (GitHub Advisory, Fix Commit).
Successful exploitation causes a crash (stack overflow) of the targeted Freeciv21 process, resulting in a complete denial of service. A remote unauthenticated attacker can crash any publicly accessible Freeciv21 server, disrupting all active game sessions. Conversely, a malicious game server can exploit connecting clients, crashing the game on the player's machine. There is no confidentiality or integrity impact; the vulnerability is purely an availability issue. Local single-player games are not affected, as Freeciv21 restricts local connections to the current user (GitHub Advisory).
No public proof-of-concept exploit code or evidence of in-the-wild exploitation has been reported. The EPSS score is approximately 0.0023 (0.23%), indicating a low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. No threat actor attribution has been identified. The attack requires no authentication and no user interaction, making it trivially exploitable against any reachable public server once the attack vector is understood (Feedly, GitHub Advisory).
freeciv21-server or freeciv21 client process; operating system crash reports (e.g., Windows Event Log application crash entries, Linux dmesg stack overflow messages, or core dump files in the working directory) (GitHub Advisory).All users should upgrade to Freeciv21 version 3.1.1, which is available across all supported package formats (snap, Windows/Mac/Debian installers, AUR, and Flatpak). The fix removes recursive compressed packet processing and adds explicit rejection of compressed packets nested within decompressed content. As a temporary workaround for non-public servers, placing the server behind a firewall to restrict network access reduces exposure. Local single-player games are not affected and require no action (GitHub Advisory, Release v3.1.1).
The vulnerability was discovered and reported by lmoureaux, a Freeciv21 maintainer, and patched in the same release cycle as disclosure (March 21, 2026). The release notes explicitly label v3.1.1 as a security release. Downstream Linux distributions including openSUSE and Mageia issued security update advisories, and Tenable published Nessus detection plugins (IDs 303284, 303285, 304224) shortly after disclosure. No significant broader media coverage or notable social media discussion has been identified (Release v3.1.1, openSUSE Advisory).
Fix availability across major Linux distributions and their releases.
bookworm
freeciv: 3.0.6-1+deb12u1
sid
freeciv: 3.2.4+ds-1
trixie
freeciv: 3.1.4+ds-2+deb13u1
bionic (esm-apps)
freeciv: 2.5.10-1ubuntu0.1~esm1
devel
freeciv
focal (esm-apps)
freeciv: 2.6.2-1ubuntu0.1~esm1
jammy
freeciv
jammy (esm-apps)
freeciv: 2.6.6-1ubuntu0.1~esm1
noble
freeciv
noble (esm-apps)
freeciv: 3.1.0+ds-1ubuntu0.1~esm1
resolute
freeciv
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."