
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-33423 is a missing authorization vulnerability in Discourse, an open-source discussion platform, that allows staff members to modify any user's group notification level without proper authorization checks. It affects Discourse versions 2026.1.0 through 2026.1.1, 2026.2.0, and 2026.3.0-latest (unpatched). The vulnerability was published on March 20, 2026, with a patch released on March 25, 2026. It carries a CVSS v3.1 base score of 4.3 (Medium) and a CVSS v4.0 base score of 1.3 (Low) (GitHub Advisory).
The root cause is classified as CWE-862 (Missing Authorization) — the application fails to enforce proper authorization checks when staff members attempt to modify group notification levels for arbitrary users. An authenticated staff-level user can send a network request to alter another user's group notification settings without being restricted to their own account or users within their administrative scope. No user interaction from the victim is required, and the attack complexity is low, requiring only a valid staff-level session (GitHub Advisory).
Successful exploitation allows staff members to arbitrarily change any user's group notification preferences, impacting the integrity of user account settings across the platform. There is no confidentiality or availability impact — the vulnerability is limited to unauthorized modification of notification levels. While not directly enabling lateral movement or data exfiltration, it could be abused to disrupt user experience or manipulate notification behavior at scale (GitHub Advisory).
No public proof-of-concept exploit code or evidence of in-the-wild exploitation has been reported. The EPSS score is approximately 0.038%, indicating a very low probability of exploitation in the near term. The vulnerability requires an authenticated staff-level account, limiting the attacker pool. It is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, and the CVSSv4 exploit maturity is rated as "Unreported" (GitHub Advisory).
Discourse has released patched versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 that address this vulnerability. Administrators should upgrade to one of these versions as soon as possible. No configuration-based workarounds are available according to the vendor advisory (GitHub Advisory).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."