
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-33869 is an incorrect authorization vulnerability in Mastodon, a free, open-source ActivityPub-based social network server, that allows an attacker with advance knowledge of a quote post to prevent it from being correctly processed on a target server. It affects Mastodon versions 4.4.0 through 4.4.14 and 4.5.0 through 4.5.7; versions 4.3 and earlier are not affected as they do not support quotes. The vulnerability was published on March 27, 2026, and patched versions were released shortly after. It carries a CVSS v3.1 base score of 4.8 (Medium) (GitHub Advisory, Red Hat).
The root cause is classified as CWE-863 (Incorrect Authorization) in Mastodon's quote processing functionality. An attacker who has advance knowledge of a quote — before it has been federated to and processed by a target server — can exploit a flaw in how authorization is handled during quote ingestion to prevent the quote from being correctly stored or displayed on that server. The attack vector is network-based, requires no privileges or user interaction, but does require high attack complexity due to the precondition of knowing about the quote prior to its arrival at the target server (GitHub Advisory).
Successful exploitation results in limited integrity and availability impacts: quotes fail to be correctly processed on the targeted Mastodon server, causing data integrity issues (quotes not properly stored or displayed) and disrupting the availability of quote functionality for affected users. There is no confidentiality impact, and the scope is unchanged, meaning the vulnerability does not enable lateral movement or broader system compromise (GitHub Advisory, Red Hat).
There is no evidence of a public proof-of-concept exploit or active in-the-wild exploitation at this time. The EPSS score is approximately 0.038%, reflecting a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. No threat actor attribution has been reported (GitHub Advisory).
Mastodon has released patched versions addressing this vulnerability: operators running the 4.4.x branch should upgrade to 4.4.15 or later, and those on the 4.5.x branch should upgrade to 4.5.8 or later. Mastodon 4.3 and earlier are not affected and require no action. No configuration-based workarounds have been published; upgrading is the recommended and only known remediation (GitHub Advisory).
The advisory was published by Mastodon maintainer renchap on GitHub, with credit to reporter ClearlyClaire. Community interest appears limited given the moderate severity and narrow exploitation preconditions. No significant media coverage or notable researcher commentary beyond the official advisory has been identified (GitHub Advisory).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."