
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-34777 is an origin validation error in the Electron framework that causes an incorrect origin to be passed to the session.setPermissionRequestHandler() callback when an embedded iframe requests certain permissions. When an iframe requests fullscreen, pointerLock, keyboardLock, openExternal, or media permissions, the handler receives the top-level page's origin instead of the requesting iframe's origin, potentially allowing third-party embedded content to be granted permissions it should not receive. The vulnerability affects Electron versions below 38.8.6, 39.0.0-alpha.1 through 39.8.1, 40.0.0-alpha.1 through 40.8.1, and 41.0.0-alpha.1 through 41.0.0. It was published on April 2–3, 2026, and carries a CVSS v3.1 base score of 5.4 (Medium) (GitHub Advisory, Electron Advisory).
The root cause is classified as CWE-346 (Origin Validation Error): Electron's permission request handling logic incorrectly propagates the top-level webContents URL as the origin when an iframe initiates a permission request, rather than the iframe's own origin. Applications that rely on the origin parameter or webContents.getURL() in their setPermissionRequestHandler callback to make access control decisions will therefore evaluate the wrong origin, potentially granting permissions to untrusted third-party iframes. The correct requesting URL is available via details.requestingUrl, and applications already using this field are unaffected. No public proof-of-concept exploit code has been identified at this time (GitHub Advisory, Electron Advisory).
Successful exploitation allows a malicious third-party iframe embedded within a trusted Electron application to obtain permissions — such as fullscreen, pointer lock, keyboard lock, access to external URLs, or media (camera/microphone) — that should be restricted to the top-level origin. This results in low confidentiality impact (e.g., unauthorized media access) and low integrity impact (e.g., UI manipulation via fullscreen or pointer lock), with no availability impact. The scope is limited to the affected Electron application's session, but the ability to hijack media or keyboard permissions could facilitate phishing or user deception attacks within the app context (GitHub Advisory).
There is no evidence of active in-the-wild exploitation or public proof-of-concept code for CVE-2026-34777 at this time. The EPSS score is approximately 0.007% (1st percentile), indicating a very low probability of exploitation in the near term. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation requires user interaction (a user must visit or interact with a page containing a malicious iframe within a vulnerable Electron app), which further limits practical exploitability (GitHub Advisory).
session.setPermissionRequestHandler() and grants permissions based on the origin parameter or webContents.getURL() rather than details.requestingUrl.<iframe src="https://attacker.example.com/malicious.html">) pointing to attacker-controlled content.element.requestFullscreen()), pointer lock (element.requestPointerLock()), or media access (navigator.mediaDevices.getUserMedia(...)).Electron has released patched versions: 38.8.6, 39.8.1, 40.8.1, and 41.0.0. Developers should upgrade to one of these versions as the primary remediation. As an immediate workaround without upgrading, modify the setPermissionRequestHandler implementation to inspect details.requestingUrl instead of the origin parameter or webContents.getURL() when making permission grant decisions for fullscreen, pointerLock, keyboardLock, openExternal, and media permissions. IBM has also issued a security bulletin for MongoDB Enterprise Advanced with IBM, which bundles Electron and is affected by this vulnerability (Electron Advisory, IBM Bulletin).
The advisory was published by GitHub user VerteDinde on behalf of the Electron security team on April 2, 2026, and subsequently reviewed and published to the GitHub Advisory Database on April 3, 2026. IBM issued a security bulletin in May 2026 noting that MongoDB Enterprise Advanced with IBM is also affected. Community discussion has been limited, consistent with the low EPSS score and absence of active exploitation (GitHub Advisory, IBM Bulletin).
Fix availability across major Linux distributions and their releases.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."