
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-4498 is a privilege abuse vulnerability (CWE-250: Execution with Unnecessary Privileges) in Kibana's Fleet plugin debug route handlers that allows authenticated users to read Elasticsearch index data beyond their authorized RBAC scope. It affects Kibana versions 8.0.0 through 8.19.13, 9.0.0 through 9.2.7, and 9.3.0 through 9.3.2. The vulnerability was published on April 8, 2026, with patches released the same day. It carries a CVSS v3.1 base score of 7.7 (High) (GitHub Advisory, Elastic Advisory).
The root cause is CWE-250 (Execution with Unnecessary Privileges): Kibana's Fleet plugin debug route handlers execute operations with elevated privileges beyond what the invoking user's Elasticsearch RBAC role permits. This constitutes a Privilege Abuse pattern (CAPEC-122), where the debug handlers act on behalf of the Kibana service account rather than enforcing the caller's RBAC constraints. Exploitation requires an authenticated Kibana session with at least one Fleet sub-feature privilege (agents, agent policies, or settings management), after which the attacker can issue requests to the Fleet debug endpoints to retrieve index data they would not normally be authorized to access (GitHub Advisory, Elastic Advisory).
Successful exploitation results in unauthorized read access to Elasticsearch index data that should be restricted by RBAC policies, representing a high confidentiality impact with no integrity or availability impact. An attacker with limited Fleet sub-feature privileges could access sensitive data stored in indices they are not directly authorized to query, potentially exposing logs, metrics, security events, or other business-sensitive information managed by Elasticsearch. The scope is marked as "Changed" in CVSS, indicating that the impact extends beyond the Kibana component itself to the broader Elasticsearch data layer (GitHub Advisory, Elastic Advisory).
As of the time of reporting, there is no public proof-of-concept exploit and no evidence of in-the-wild exploitation (Elastic Advisory). The EPSS score is approximately 0.046% (0.000460), placing it in a low probability tier for near-term exploitation. No threat actor attribution has been reported, and the vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Exploitation does require valid Kibana credentials with Fleet sub-feature privileges, which limits the attack surface to authenticated insiders or compromised accounts.
Elastic has released patched versions: 8.19.14, 9.2.8, and 9.3.3 — upgrading to one of these versions is the primary recommended remediation (Elastic Advisory). As interim mitigations, administrators should review and restrict Fleet sub-feature privileges (agents, agent policies, settings management) to only users who operationally require them, and implement network-level controls to limit Kibana access to trusted networks. Audit Kibana and Elasticsearch access logs for any anomalous index reads via Fleet debug handlers.
Elastic published a security advisory (ESA-2026-21) on April 8, 2026, coinciding with the release of patched versions (Elastic Advisory). The vulnerability received routine coverage from vulnerability tracking platforms and automated social media accounts (Bluesky, Mastodon) shortly after disclosure, with no notable researcher commentary or significant community debate observed. Red Hat also published a CVE entry for the vulnerability given Kibana's inclusion in some Red Hat product offerings.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."