
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-81648 is a critical Missing Authorization vulnerability in the CryptoPayment Gateway WordPress plugin affecting versions 1.2.1 through 1.2.2. The flaw allows unauthenticated attackers to invoke administrative operations via an unguarded AJAX endpoint, including deleting arbitrary files, overwriting payment gateway configuration, and recovering stored wallet credentials in cleartext. It was publicly disclosed on September 10, 2026, and assigned a CVSS v3.1 base score of 10.0 (Critical) (WPScan, GitHub Advisory).
The root cause is CWE-862 (Missing Authorization): the plugin's AJAX router does not enforce any authentication or capability checks before executing privileged administrative actions (GitHub Advisory). An unauthenticated remote attacker can send crafted HTTP requests directly to the exposed WordPress AJAX endpoint (admin-ajax.php) to trigger file deletion, configuration overwrite, or credential retrieval without any prior authentication. The vulnerability is classified under OWASP Top 10 A5: Broken Access Control, and WPScan notes that a proof-of-concept was scheduled for public release on October 1, 2026, to allow time for users to update (WPScan).
Successful exploitation allows a fully unauthenticated network attacker to delete arbitrary files on the web server (potentially causing denial of service or enabling further attacks), overwrite payment gateway configuration (enabling payment redirection or fraud), and retrieve stored cryptocurrency wallet credentials in plaintext (leading to direct financial theft). The changed scope in the CVSS rating reflects that the impact extends beyond the WordPress plugin itself to the underlying server and connected payment/wallet infrastructure (GitHub Advisory, WPScan).
As of the disclosure date, there is no confirmed evidence of in-the-wild exploitation, and no public proof-of-concept exploit has been released — WPScan planned to publish a PoC on October 1, 2026 (WPScan). The vulnerability is rated automatable by NVD SSVC, requiring no privileges or user interaction, making it highly amenable to mass scanning and exploitation. The EPSS score is approximately 0.28–0.50% (varying by source), and the CVE status is listed as "Deferred" with no CISA KEV catalog entry at this time (GitHub Advisory). The vulnerability was discovered and reported by researcher Pedro Pinho (WPScan).
/wp-content/plugins/cryptopayment-gateway/).wp-admin/admin-ajax.php. Review plugin source code (publicly available via WordPress.org SVN) to identify the specific action parameter value used by the unprotected router.https://target.com/wp-admin/admin-ajax.php with the appropriate action parameter and any required payload parameters (e.g., file path for deletion, new configuration values, or credential retrieval trigger)./wp-admin/admin-ajax.php with plugin-specific action parameter values from unknown or scanning IP addresses; repeated requests in short succession suggesting automated exploitation.POST /wp-admin/admin-ajax.php with no authenticated session cookie; server error logs indicating file deletion operations or configuration writes triggered outside normal admin sessions.WPScan's advisory notes there is "no known fix" for the affected versions 1.2.1–1.2.2 at the time of disclosure, though a patch is referenced in GitHub Advisory GHSA-9r3q-6qw8-8pm7 (GitHub Advisory). Site administrators should immediately deactivate and remove the CryptoPayment Gateway plugin if no patched version is available, or update to any version newer than 1.2.2 once released. Additionally, administrators should rotate all exposed wallet credentials and payment gateway API keys, review server logs for unauthorized file deletions or configuration changes, and restrict access to wp-admin/admin-ajax.php at the network or WAF level where feasible (WPScan).
Wordfence included this vulnerability in its weekly WordPress vulnerability report for the period of September 7–13, 2026, highlighting it among notable critical issues (Wordfence Blog). A Reddit thread in r/StopBadBots flagged this CVE as part of a broader discussion about unpatched critical WordPress plugins, reflecting community concern about the payment-related attack surface (Reddit).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."