Vulnerability DatabaseGHSA-j82w-28jv-3pmj

GHSA-j82w-28jv-3pmj: 
Ruby vulnerability analysis and mitigation

Impact

Within the URI template implementation in Addressable, templates using the * (explode) modifier with the /, ., ;, ? or & operators (e.g., {/segments*}, {.ext*}, {;params*}, {?query*}) generate regular expressions vulnerable to catastrophic backtracking. When Template#match or Template#extract is called with a maliciously crafted URI that starts with the operator's leading character, matching takes exponential time, leading to uncontrolled resource consumption and denial of service. An input under 60 bytes is enough to occupy a thread for minutes. GHSA-h27x-rffw-24p4 (CVE-2026-35611) reported this pattern as fully remediated in 2.9.0. The 2.9.0 fix only made the joiner between exploded members mandatory for templates without an operator, and its regression specs used inputs that never start with the operator's leading character, so the vulnerable part of the expression was never reached. This issue was originally reported in #364 by @ebenoist in 2019 but insufficiently investigated. Users of the URI parsing capabilities in Addressable but not the URI template matching capabilities are unaffected. Users who only call Template#expand are unaffected.

Affected Versions

This vulnerability affects Addressable >= 2.3.0 (note: 2.3.0 and 2.3.1 were yanked; the earliest installable release is 2.3.2), including 2.9.0. It is fixed in 2.9.1. The vulnerability is only exploitable on Ruby implementations whose regular expression engine backtracks without memoization: MRI Ruby < 3.2 and JRuby. MRI Ruby 3.2 and later are not affected: their regular expression engine memoizes backtracking, so these patterns still match in linear time. TruffleRuby 40.0 is not affected either. Earlier TruffleRuby versions were not tested. This has been confirmed on the following runtimes with Addressable 2.9.0:

RuntimeStatus
MRI Ruby 2.7Vulnerable
MRI Ruby 3.1Vulnerable
MRI Ruby 3.2Not affected
MRI Ruby 3.3Not affected
MRI Ruby 3.4Not affected
MRI Ruby 4.0Not affected
JRuby 9.4Vulnerable
TruffleRuby 40.0Not affected

Workarounds

  • Upgrade to MRI Ruby 3.2 or later, if your application does not use JRuby.
  • Avoid matching user-supplied input on unpatched versions of the library against templates that use the * modifier with the /, ., ;, ? or & operators.
  • Apply a short timeout around any call to Template#match or Template#extract that processes user-supplied data.

References

Credits

Reported independently by @ebenoist, @andrewstellman, and then @halogenandtoast.

For more information

If you have any questions or comments about this advisory:


Source: NVD

Related Ruby vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-61845HIGH8.9
  • Ruby logoRuby
  • crass
NoYesOct 30, 2026
CVE-2026-63414HIGH7.6
  • Ruby logoRuby
  • shopify_app
NoYesOct 30, 2026
CVE-2026-61848MEDIUM6.3
  • Ruby logoRuby
  • ruby-crass
NoYesOct 30, 2026
CVE-2026-61847MEDIUM6.3
  • Ruby logoRuby
  • crass
NoYesOct 30, 2026
CVE-2026-61846MEDIUM6.3
  • Ruby logoRuby
  • ruby-crass
NoYesOct 30, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management