
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2025-67731 is a Denial of Service (DoS) vulnerability in the servify-express npm package, a Node.js utility for quickly starting an Express server. The flaw stems from the package using express.json() without a request body size limit, allowing unauthenticated attackers to send arbitrarily large JSON payloads and exhaust server resources. All versions prior to 1.2 (i.e., <= 1.1) are affected. The vulnerability was published on December 11, 2025, with a CVSS v3.1 score of 7.5 (High) and a CVSS v4.0 score of 8.7 (High) (Github Advisory).
The root cause is classified as CWE-770 (Allocation of Resources Without Limits or Throttling) — specifically, the index.js of servify-express registers app.use(express.json()) without specifying a limit option, meaning the Express JSON body parser will attempt to parse any payload regardless of size (Github Advisory). An unauthenticated remote attacker can exploit this by sending HTTP POST requests with extremely large JSON bodies to any endpoint exposed by the vulnerable server. No authentication, special privileges, or user interaction is required. The flaw is a misconfiguration in the wrapper package rather than a bug in Express itself; the fix (commit 8dff7f5) adds optional rate limiting middleware and the advisory recommends setting express.json({ limit: '100kb' }) (Patch Commit).
Successful exploitation results in high availability impact: excessive memory consumption, degraded server performance, or complete process crashes leading to a Denial of Service condition. There is no confidentiality or integrity impact — attackers cannot read data or modify system state through this vulnerability. Any application built on servify-express versions <= 1.1 and exposed to untrusted network clients is at risk (Github Advisory).
There is no public proof-of-concept exploit code and no evidence of in-the-wild exploitation at this time (Github Advisory). The EPSS score is approximately 0.046% (0.000460), placing it in a low-probability exploitation tier. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. Despite the low exploitation probability, the attack requires no authentication and no user interaction, making it trivially automatable against exposed instances.
servify-express versions <= 1.1, potentially via npm dependency scanning tools, Shodan, or Censys searches for Node.js/Express servers.Content-Type: application/json header.Content-Length) to any endpoint on the affected server; high volume of concurrent POST requests from one or multiple source IPs.top, htop, or APM agents); unexpected process restarts or crashes of the node process running servify-express.Upgrade servify-express to version 1.2 or later, which introduces optional rate limiting middleware via express-rate-limit (Github Advisory, Patch Commit). If immediate upgrade is not possible, apply one or more of the following workarounds:
app.use(express.json({ limit: '100kb' }))express-rate-limitSource: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."