
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-26081 is a vulnerability in HAProxy Community Edition affecting versions 3.0 through 3.3 before 3.3.3, caused by a missing length check for the NEW_TOKEN format. HAProxy Enterprise and ALOHA are also affected. The vulnerability was published on July 20, 2026, and carries a CVSS v3.1 base score of 4.8 (Medium) (GitHub Advisory). Affected version ranges include 3.0.x before 3.0.12, 3.1.x before 3.1.14, 3.2.x before 3.2.12, and 3.3.x before 3.3.3 (GitHub Advisory).
The root cause is classified as CWE-130 (Improper Handling of Length Parameter Inconsistency), where HAProxy fails to validate the length field of the NEW_TOKEN format against the actual length of the associated data (GitHub Advisory). This is a network-accessible flaw requiring no authentication or user interaction, though exploitation is rated as high complexity. The associated attack pattern is CAPEC-47 (Buffer Overflow via Parameter Expansion), suggesting that a crafted token with a mismatched length field could trigger unexpected behavior in the parsing logic. A fix commit is publicly available in the HAProxy 3.2 repository (GitHub Advisory).
Successful exploitation results in limited integrity and availability impacts — specifically, low-severity disruption to HAProxy's availability and minor integrity degradation — with no confidentiality impact. Because HAProxy commonly serves as a load balancer or reverse proxy in front of critical infrastructure, even limited availability disruption could affect downstream services. The technical impact is assessed as partial, and exploitation is not considered automatable (GitHub Advisory).
No public proof-of-concept exploit code or in-the-wild exploitation has been reported for CVE-2026-26081. The NVD SSVC assessment indicates exploitation is "none" and the vulnerability is not automatable. The EPSS score is approximately 0.363%, placing it in the 29th percentile for exploitation likelihood within 30 days. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog (GitHub Advisory).
Users should upgrade HAProxy Community Edition to one of the following patched versions: 3.0.12, 3.1.14, 3.2.12, or 3.3.3. HAProxy Enterprise and ALOHA users should consult their vendor for corresponding patched releases. The fix is available in the HAProxy source repository (e.g., commit 4765277f4f915baac2d57db63538ff0a59966deb for the 3.2 branch). Debian, Ubuntu, and openSUSE have issued distribution-level advisories with updated packages (GitHub Advisory).
HAProxy published a blog post addressing CVE-2026-26081 alongside related QUIC denial-of-service issues, framing it as part of a broader set of fixes in the 3.x release series (HAProxy Blog). Debian issued DSA-6130-1 and Ubuntu issued USN-8036-1 covering this vulnerability, and openSUSE also released a security update. Coverage has been largely routine, with no significant researcher controversy or social media amplification noted.
Fix availability across major Linux distributions and their releases.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."