
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-48447 is an Incorrect Authorization vulnerability (CWE-863) in Adobe Lightroom Classic that could result in arbitrary code execution in the context of the current user. It affects Lightroom Classic versions 15.4 and earlier (including 15.4.1, 15.3, 15.3.1, 15.2, and 15.2.1) on Windows platforms. Adobe disclosed and patched the vulnerability on August 11, 2026, as part of security bulletin APSB26-94. It carries a CVSS v3.1 base score of 7.7 (High) (Adobe Advisory, GitHub Advisory).
The vulnerability is classified as CWE-863 (Incorrect Authorization), meaning the application fails to correctly perform authorization checks when processing certain file inputs, allowing an attacker to bypass intended access controls and trigger arbitrary code execution. The attack vector is local with high attack complexity, requires no privileges, but does require user interaction — specifically, a victim must open a malicious file crafted by the attacker. Exploitation success also depends on conditions beyond the attacker's control, and the scope is noted as changed, indicating that a successful exploit can impact resources beyond the vulnerable component itself (Adobe Advisory, GitHub Advisory).
Successful exploitation allows an attacker to execute arbitrary code in the context of the current user on Windows systems running vulnerable versions of Adobe Lightroom Classic. The technical impact is rated as total, meaning confidentiality, integrity, and availability are all highly impacted — an attacker could access sensitive photo libraries and user data, modify or delete files, and potentially disrupt application availability. The changed scope indicates the exploit may affect resources or components beyond Lightroom itself, raising the risk of broader system compromise (Adobe Advisory, GitHub Advisory).
There is currently no public proof-of-concept exploit and no evidence of active in-the-wild exploitation for CVE-2026-48447. CISA's SSVC assessment classifies exploitation as "none" and the vulnerability as non-automatable, reflecting the requirement for user interaction and high attack complexity. The EPSS score is approximately 0.144% (4th percentile), indicating a low near-term probability of exploitation. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog (Adobe Advisory, GitHub Advisory).
Adobe has released Lightroom Classic version 15.5 as the patched release, addressing this vulnerability on Windows platforms. Users should update to version 15.5 or later immediately via the Adobe Creative Cloud desktop application or Adobe's official update channels. As a precautionary measure, users should avoid opening Lightroom catalog or image files received from untrusted or unknown sources. Organizations may also consider applying application whitelisting or file execution policies to reduce exposure (Adobe Advisory).
The Center for Internet Security (CIS) issued an advisory noting that multiple Adobe product vulnerabilities disclosed in August 2026, including CVE-2026-48447, could allow for arbitrary code execution. Security aggregators such as VulDB and threat intelligence platforms tracked the vulnerability shortly after disclosure. No notable independent researcher commentary or significant social media discussion has been identified beyond standard vulnerability tracking coverage (CIS Advisory).
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."