
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-73064 is a TLS stream integrity vulnerability in Mbed TLS affecting TLS 1.3 servers, classified as an insufficient entropy / unexpected return value issue. An attacker who can cause an entropy source to fail may remove or inject bytes into the start of the TLS stream, compromising communication integrity. Affected versions are Mbed TLS 3.2.0 through 3.6.6 and 4.0.0 through 4.1.0; fixed versions are 3.6.7+ and 4.1.1+. It was published on September 24, 2026, with a CVSS v3.1 base score of 2.9 (Low) (GitHub Advisory, Red Hat Bugzilla).
The vulnerability is rooted in improper handling of entropy source failures (CWE-394: Unexpected Status Code or Return Value; CWE-331: Insufficient Entropy). When an entropy source fails during TLS 1.3 server operation, Mbed TLS does not correctly detect or handle the failure condition, allowing an attacker with local access to manipulate the entropy source and thereby inject or remove bytes at the beginning of the TLS stream. Exploitation requires high attack complexity and local access, as the attacker must be able to deliberately cause the entropy source to fail — a precondition that limits the practical attack surface. The official security advisory is referenced at the Mbed TLS ReadTheDocs security advisories page (GitHub Advisory, Mbed TLS Repo).
Successful exploitation results in a low-integrity impact on TLS 1.3 server communications — specifically, an attacker can inject or remove bytes at the start of the TLS stream, potentially corrupting or manipulating the initial handshake or data exchange. There is no confidentiality or availability impact, and the scope is unchanged, meaning the attack does not propagate beyond the affected component. The vulnerability is limited to TLS 1.3 server deployments using Mbed TLS; TLS 1.2 servers and clients are not affected (GitHub Advisory, Red Hat Bugzilla).
There is no public proof-of-concept exploit and no evidence of in-the-wild exploitation as of the time of publication (GitHub Advisory). The EPSS score is approximately 0.102% (1st percentile), indicating a very low probability of exploitation in the near term. The NVD SSVC assessment confirms exploitation is currently "none" and the attack is not automatable. No threat actor attribution has been reported, and the vulnerability is not listed in the CISA Known Exploited Vulnerabilities catalog.
Users should upgrade Mbed TLS to version 3.6.7 or later (for the 3.x branch) or version 4.1.1 or later (for the 4.x branch) to remediate this vulnerability (GitHub Advisory). As a defense-in-depth measure, operators should implement monitoring and access controls to protect entropy sources from deliberate failure, and harden deployment environments to minimize local attacker access. Deployments not using TLS 1.3 in server mode are not affected and do not require immediate action.
Red Hat has tracked the issue via Bugzilla (Bug 2540160) with a low severity rating, and Microsoft has acknowledged the CVE in its Security Response Center update guide (Red Hat Bugzilla, Microsoft). Coverage has appeared in open-source security aggregators such as Mageia advisories and Linux security news sites, reflecting routine patch tracking rather than significant community alarm given the low CVSS score and limited exploitability.
Fix availability across major Linux distributions and their releases.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."