CVE-2026-78134: 
strongSwan vulnerability analysis and mitigation

Overview

CVE-2026-78134 is an Incorrect Authorization vulnerability in strongSwan's eap-ttls and eap-peap plugins caused by missing or mismatched inner EAP identity propagation, which can result in incorrect identity binding and potential authorization bypass. It affects strongSwan versions 4.5.0 through 6.0.7 (fixed in 6.1.0). The vulnerability was disclosed on September 7, 2026, when strongSwan released version 6.1.0, and was published to NVD on September 11, 2026. It carries a CVSS v3.1 base score of 7.1 (High) (GitHub Advisory, strongSwan Release).

Technical details

The root cause is classified as CWE-863 (Incorrect Authorization). In EAP-TTLS and EAP-PEAP tunneled authentication, the outer TLS tunnel establishes a protected channel within which an inner EAP method authenticates the client. The vulnerability arises because the plugins fail to properly propagate or validate the inner EAP identity against the outer identity, allowing a scenario where the authenticated inner identity is missing or mismatched — effectively decoupling the authorization decision from the actual authenticated principal. An attacker with network access and low-level credentials (e.g., a valid outer TLS session) could exploit this to impersonate another identity or bypass access controls enforced on the inner EAP identity (GitHub Advisory, strongSwan Release).

Impact

Successful exploitation allows an authenticated network attacker to bypass EAP-TTLS or EAP-PEAP authentication controls, gaining unauthorized access to VPN tunnels or protected network resources that should be restricted to specific identities. The CVSS assessment reflects high confidentiality and integrity impact (an attacker can access and potentially manipulate resources they are not authorized for) with low availability impact. In VPN environments, this could enable lateral movement into internal network segments or access to sensitive organizational resources (GitHub Advisory, strongSwan Release).

Exploitability

There is no public proof-of-concept exploit and no evidence of in-the-wild exploitation at this time. The vulnerability requires the attacker to already hold some level of authentication (low privileges required) and involves high attack complexity, limiting opportunistic exploitation. The EPSS score is approximately 0.0032 (0.32%), indicating a low near-term exploitation probability. The vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities (KEV) catalog. NVD's SSVC assessment classifies exploitation as "none" and the attack as non-automatable (GitHub Advisory, Feedly).

Mitigation and workarounds

The primary remediation is to upgrade strongSwan to version 6.1.0 or later, which includes the fix for CVE-2026-78134 by properly propagating authentication details from inner EAP methods to enforce correct identity binding (strongSwan Release). Organizations unable to patch immediately should review VPN access logs for suspicious authentication patterns or unexpected tunnel establishments, and consider implementing additional identity verification measures beyond EAP authentication. Prioritize patching systems actively using the eap-ttls or eap-peap plugins in production VPN environments. Patches have also been distributed via SUSE, openSUSE, Debian, Ubuntu, and FreeBSD security updates (Feedly).

Community reactions

The strongSwan project disclosed the vulnerability proactively as part of the 6.1.0 release on September 7, 2026, publishing a dedicated blog post at https://www.strongswan.org/blog/2026/09/07/strongswan-vulnerability-(cve-2026-78134).html. Major Linux distributions including SUSE, openSUSE, Debian, and Ubuntu issued security advisories and updated packages shortly after disclosure. Microsoft also published a security advisory for the CVE. Community coverage was primarily technical and focused on patch distribution across distributions (strongSwan Release, GitHub Advisory).

Additional resources

Linux Distribution fix status

Fix availability across major Linux distributions and their releases.

Debian

Fixed

bookworm

strongswan

Affected

sid

strongswan: 6.1.0-1

Fixed

trixie

strongswan: 6.0.1-6+deb13u7

Fixed

Ubuntu

Fixed

bionic (esm-infra)

strongswan

Unknown

bionic (fips-updates)

strongswan

Unknown

bionic (fips)

strongswan

Unknown

devel

strongswan

Not Affected

focal (esm-infra)

strongswan

Unknown

focal (fips-updates)

strongswan

Unknown

focal (fips)

strongswan

Unknown

jammy

strongswan: 5.9.5-2ubuntu2.8

Fixed

Alpine

Fixed

edge

strongswan: 6.1.0-r0

Fixed

Source: This report was generated using AI

Related strongSwan vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-78133HIGH7.5
  • strongSwan logostrongSwan
  • strongswan
NoYesSep 11, 2026
CVE-2026-78132HIGH7.5
  • strongSwan logostrongSwan
  • strongswan
NoYesSep 11, 2026
CVE-2026-78135HIGH7.3
  • strongSwan logostrongSwan
  • strongswan-libs0
NoYesSep 11, 2026
CVE-2026-78134HIGH7.1
  • strongSwan logostrongSwan
  • cpe:2.3:a:strongswan:strongswan
NoYesSep 11, 2026
CVE-2026-78131LOW3.7
  • strongSwan logostrongSwan
  • strongswan-ipsec
NoYesSep 11, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management